Node v0.4.8

2011.05.20, Version 0.4.8 (stable)

* #974 Properly report traceless errors (isaacs)

* #983 Better JSON.parse error detection in REPL (isaacs)

* #836 Agent socket errors bubble up to req only if req exists

* #1041 Fix event listener leak check timing (koichik)

* #1038 Fix dns.resolve() with ‘PTR’ throws Error: Unknown type “PTR”
(koichik)

* #1073 Share SSL context between server connections (Fedor Indutny)

* Disable compression with OpenSSL. Improves memory perf.

* Implement os.totalmem() and os.freemem() for SunOS (Alexandre Marangone)

* Fix a special characters in URL regression (isaacs)

* Fix idle timeouts in HTTPS (Felix Geisendörfer)

* SlowBuffer.write() with ‘ucs2’ throws ReferenceError. (koichik)

* http.ServerRequest ‘close’ sometimes gets an error argument
(Felix Geisendörfer)

* Doc improvements

* cleartextstream.destroy() should close(2) the socket. Previously was being
mapped to a shutdown(2) syscall.

* No longer compile out asserts and debug statements in normal build.

* Debugger improvements.

* Upgrade V8 to 3.1.8.16.

Website: http://nodejs.org/docs/v0.4.8/

Download: http://nodejs.org/dist/node-v0.4.8.tar.gz

Documentation: http://nodejs.org/docs/v0.4.8/api/

This entry was posted in Uncategorized. Bookmark the permalink.

4 Responses to Node v0.4.8

  1. Ivan says:

    Hello I’m newbie in Node. Could you please help me: I could not install it with nvm:

    ivan@ivan-laptop:~$ nvm install latest
    ####################################################################### 100.0%
    curl: (33) HTTP server doesn’t seem to support byte ranges. Cannot resume.
    nvm: install v0.4.8-rc failed!

    any suggestions?

    • fumanchu182 says:

      You may want to try running that command as a super user in the system.

    • Steve says:

      I had the same problem:

      From https://github.com/creationix/nvm:
      If you try to install a node version and the installation fails, be sure to delete the node downloads from src (~/.nvm/src/) or you might get an error when trying to reinstall them again or you might get an error like the following:

      curl: (33) HTTP server doesn’t seem to support byte ranges. Cannot resume.

  2. Brian says:

    I’ve set up my own blog at: http://node-dot-js.blogspot.com/

    I hope to provide some tips and code examples for other developers who are new to node.js and wish to be given everything they need to get started.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s